如何解决错误;’错误:Bootstrap工具提示需要系绳(http://github.hubspot.com/tether/)’

2020/10/21 23:02 · javascript ·  · 0评论

我正在使用Bootstrap V4,控制台中记录了以下错误;

错误:Bootstrap工具提示需要Tether(http://github.hubspot.com/tether/

我试图通过安装Tether来消除错误,但没有成功。我通过包含以下代码行来“安装” Tether;

<link rel="stylesheet" href="http://www.atlasestateagents.co.uk/css/tether.min.css">
<script src="http://www.atlasestateagents.co.uk/javascript/tether.min.js"></script>

我是否正确“安装”了系绳?

谁能帮我消除此错误?

如果您想在我的网站上查看错误,请单击此处并加载控制台。

对于Bootstrap 4稳定版:

由于beta版Bootstrap 4不依赖于Tether而是Popper.js所有脚本(必须按此顺序):

<script src="https://code.jquery.com/jquery-3.3.1.slim.min.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.3/umd/popper.min.js"></script>
<script src="https://stackpath.bootstrapcdn.com/bootstrap/4.1.1/js/bootstrap.min.js"></script>

请参阅当前文档以获取最新的脚本版本。


仅Bootstrap 4 alpha:

引导4阿尔法需要系绳,所以你需要包括tether.min.js 之前你有bootstrap.min.js,例如。

<script src="https://npmcdn.com/tether@1.2.4/dist/js/tether.min.js"></script>
<script src="https://npmcdn.com/bootstrap@4.0.0-alpha.5/dist/js/bootstrap.min.js"></script>

如果您使用的是Webpack:

  1. 按照文档所述设置bootstrap-loader;
  2. 通过npm安装tether.js;
  3. 将tether.js添加到webpack ProvidePlugin插件中。

webpack.config.js:

plugins: [
        <... your plugins here>,
        new webpack.ProvidePlugin({
            $: "jquery",
            jQuery: "jquery",
            "window.jQuery": "jquery",
            "window.Tether": 'tether'
        })
    ]

资源

如果您使用npm和browserify:

// es6 imports
import tether from 'tether';
global.Tether = tether;

// require
global.Tether = require('tether');

我个人使用的是Bootstrap功能的一小部分,不需要附加Tether。

这应该有助于:

window.Tether = function () {
  throw new Error('Your Bootstrap may actually need Tether.');
};

如果要避免该错误消息,并且您没有使用Bootstrap工具提示,则可以在加载Bootstrap之前定义window.Tether。

<script>
  window.Tether = {};
</script>
<script src="js/bootstrap.min.js"></script>

您应该完成我的指南:

1.将波纹管源添加到Gemfile中

source 'https://rails-assets.org' do
  gem 'rails-assets-tether', '>= 1.1.0'
end
  1. 运行命令:

    捆绑安装

  2. 在application.js中的jQuery之后添加此行。

    // =需要jQuery

    // =需要系绳

  3. 重新启动Rails服务器。

通过npm安装系绳,如下所示

npm install tether --save-dev

然后将系绳添加到您的html以上的bootstrap中,如下所示

<script src="node_modules/tether/dist/js/tether.min.js"></script>
<script src="jspm_packages/github/twbs/bootstrap@4.0.0-alpha.2/js/bootstrap.js"></script>

对于webpack,我使用以下命令解决了此问题webpack.config.js

new webpack.ProvidePlugin({
  $: 'jquery',
  jQuery: 'jquery',
  "window.jQuery": "jquery",
  Tether: 'tether'
})

附加说明。如果您检查未压缩的javascript文件,则会发现以下情况:

if(window.Tether === undefined) {
     throw new Error('Bootstrap tooltips require Tether (http://github.hubspot.com/tether)')
}

因此错误消息包含必需的信息。

您可以从该链接下载档案

未压缩版本:

https://rawgit.com/HubSpot/tether/master/src/js/tether.js
https://rawgit.com/HubSpot/tether/master/dist/css/tether.css

使用webpack我在webpack.config.js

var plugins = [

    ...

    new webpack.ProvidePlugin({
        $: "jquery",
        jQuery: "jquery",
        'window.jQuery': 'jquery',
        'window.Tether': 'tether',
        tether: 'tether',
        Tether: 'tether'
    })
];

似乎Tether正是它要寻找的那个:

var Tooltip = function ($) {

  /**
   * Check for Tether dependency
   * Tether - http://tether.io/
   */
  if (typeof Tether === 'undefined') {
    throw new Error('Bootstrap tooltips require Tether (http://tether.io/)');
  }

我在使用最新的boostrap 4版本的requirejs遇到了这个问题。我最后只是定义:

<script>
  window.Tether = {};
</script>

在我的html head标签中以愚弄引导程序的检查。然后,我在需要加载我的应用程序之前添加了第二条require语句,随后添加了我的引导依赖项:

require(['tether'], function (Tether) {
  window.Tether = Tether;
});

require([
  "app",
], function(App){
  App.initialize();
});

串联使用这两个选项,使用当前的bootstrap 4 alpha构建应该没有问题。

适用于generator-aspnetcore-spa和bootstrap 4。

// ===== file: webpack.config.vendor.js =====    
module.exports = (env) => {
...
    plugins: [
        new webpack.ProvidePlugin({ $: 'jquery', 
                                    jQuery: 'jquery',
                                    'window.jQuery': 'jquery',
                                    'window.Tether': 'tether',
                                    tether: 'tether', 
                                    Tether: 'tether' }), 
// Maps these identifiers to the jQuery package 
// (because Bootstrap expects it to be a global variable)
            ...
        ]
};

对于带有Bootstrap 4的Webpack 1或2,您需要

new webpack.ProvidePlugin({
   $: 'jquery',
   jQuery: 'jquery',
   Tether: 'tether'
})

如果您使用的是早午餐,则可以在末尾添加brunch-config.js

npm: {
    enabled: true,
    globals: {
        $: 'jquery', jQuery: 'jquery', 'Tether': 'tether'
    }
}

如果您使用require.js AMD加载器:

// path config
requirejs.config({
  paths: {
    jquery: '//cdnjs.cloudflare.com/ajax/libs/jquery/3.2.1/core.js',
    tether: '//cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min',
    bootstrap: '//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/4.0.0-alpha.6/js/bootstrap.min',
  },
  shim: {
    bootstrap: {
      deps: ['jquery']
    }
  }
});

//async loading
requirejs(['tether'], function (Tether) {
  window.Tether = Tether;
  requirejs(['bootstrap']);
});

对于在那里运行Bootstrap4的Laravel Mix用户,您将需要运行

npm installer tether --save

然后更新您resources/assets/js/bootstrap.js以加载Tether并将其带到window对象。

这是我的样子:(请注意,我也必须运行npm install popper.js --save

window.$ = window.jQuery = require('jquery');
window.Popper = require('popper.js').default;
window.Tether = require('tether');
require('bootstrap');

添加到@adilapapaya的答案。对于ember-cli特定用户,请tether使用

bower install --save tether

然后ember-cli-build.js在引导之前将其包含在文件中,如下所示:

// tether (bootstrap 4 requirement)
app.import('bower_components/tether/dist/js/tether.min.js');

// bootstrap
app.import('bower_components/bootstrap/scss/bootstrap-flex.scss');
app.import('bower_components/bootstrap/dist/js/bootstrap.js');

如果使用webpack,则需要暴露插件。在您的webpack.config.js中,添加此加载器

{
   test: require.resolve("tether"),
   loader: "expose?$!expose?Tether"
}

我遇到了同样的问题,这就是我解决的方法。我在5.1.0rc1上

确保在application.js文件中添加require jquery和tether,它们必须像这样最顶部

//= require jquery
//= require tether

只要确保已安装系绳

方法1:从此处下载并插入到您的项目中;
方法2:在引导脚本源之前使用以下代码:

<script src="https://npmcdn.com/tether@1.2.4/dist/js/tether.min.js"></script>

我建议遵循Bootstrap 4文档中的说明

将样式表复制粘贴<link>到您的<head>所有其他样式表之前,以加载我们的CSS。

<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-alpha.6/css/bootstrap.min.css" integrity="sha384-rwoIResjU2yc3z8GV/NPeZWAv56rSmLldC3R/AZzGRnGxQQKnKkoFVhFQhNUwEyJ" crossorigin="anonymous">

在结束标记之前,在页面结尾附近添加我们的JavaScript插件,jQuery和Tether。请确保首先放置jQuery和Tether,因为我们的代码取决于它们。虽然我们在文档中使用jQuery的苗条版本,但也支持完整版本。

<script src="https://code.jquery.com/jquery-3.1.1.slim.min.js" integrity="sha384-A7FZj7v+d/sdmMqp/nOQwliLvUsJfDHW+k9Omg/a/EheAdgtzNs3hpfag6Ed950n" crossorigin="anonymous"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js" integrity="sha384-DztdAPBWPRXSA/3eYEEUWrWCy7G5KFbe8fFjk5JAIxUYHKkDx6Qin1DkWx51bBrb" crossorigin="anonymous"></script>
<script src="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-alpha.6/js/bootstrap.min.js" integrity="sha384-vBWWzlZJ8ea9aCX4pEW3rVHjgjt7zpkNpZk+02D9phzyeVkE+jo0ieGizqPLForn" crossorigin="anonymous"></script>

UMD / AMD解决方案

对于那些通过UMD进行操作并通过进行编译的人require.js,有一个简单的解决方案。

在需要tether作为依赖项,Tooltip作为UMD加载的模块中,在模块定义之前,只需在Tether的定义中添加简短的代码段即可:

// First load the UMD module dependency and attach to global scope
require(['tether'], function(Tether) {
    // @todo: make it properly when boostrap will fix loading of UMD, instead of using globals
    window.Tether = Tether; // attach to global scope
});

// then goes your regular module definition
define([
    'jquery',
    'tooltip',
    'popover'
], function($, Tooltip, Popover){
    "use strict";
    //...
    /*
        by this time, you'll have window.Tether global variable defined,
        and UMD module Tooltip will not throw the exception
    */
    //...
});

实际上,这个简短的代码片段可以放在应用程序的任何更高级别上,这是最重要的-在实际使用bootstrap具有Tether依赖关系组件之前调用它

// ===== file: tetherWrapper.js =====
require(['./tether'], function(Tether) {
    window.Tether = Tether; // attach to global scope
    // it's important to have this, to keep original module definition approach
    return Tether;
});

// ===== your MAIN configuration file, and dependencies definition =====
paths: {
    jquery: '/vendor/jquery',
    // tether: '/vendor/tether'
    tether: '/vendor/tetherWrapper'  // @todo original Tether is replaced with our wrapper around original
    // ...
},
shim: { 
     'bootstrap': ['tether', 'jquery']       
}

UPD:在自举4.1稳定他们取代系绳,与Popper.js,看到上使用的文档

我有同样的问题,我在包含任何js之前都包含了jquery-3.1.1.min来解决了这个问题,它的工作原理很吸引人。希望能帮助到你。

本文地址:http://javascript.askforanswer.com/ruhejiejuecuowucuowubootstrapgongjutishixuyaoxishenghttp-github-hubspot-com-tether.html
文章标签: ,   ,   ,  
版权声明:本文为原创文章,版权归 javascript 所有,欢迎分享本文,转载请保留出处!

文件下载

老薛主机终身7折优惠码boke112

上一篇:
下一篇:

评论已关闭!